CVE-2007-1582

MEDIUM

Description

The resource system in PHP 4.0.0 through 4.4.6 and 5.0.0 through 5.2.1 allows context-dependent attackers to execute arbitrary code by interrupting certain functions in the GD (ext/gd) extension and unspecified other extensions via a userspace error handler, which can be used to destroy and modify internal resources.

References

http://secunia.com/advisories/24542

http://www.php-security.org/MOPB/MOPB-27-2007.html

http://www.securityfocus.com/bid/23046

https://www.exploit-db.com/exploits/3525

Details

Source: MITRE

Published: 2007-03-21

Updated: 2018-10-30

Risk Information

CVSS v2.0

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM