CVE-2007-0720

MEDIUM

Description

The CUPS service on multiple platforms allows remote attackers to cause a denial of service (service hang) via a "partially-negotiated" SSL connection, which prevents other requests from being accepted.

References

http://docs.info.apple.com/article.html?artnum=305214

http://fedoranews.org/cms/node/2785

http://lists.apple.com/archives/security-announce/2007/Mar/msg00002.html

http://secunia.com/advisories/24479

http://secunia.com/advisories/24517

http://secunia.com/advisories/24530

http://secunia.com/advisories/24660

http://secunia.com/advisories/24878

http://secunia.com/advisories/24895

http://secunia.com/advisories/25119

http://secunia.com/advisories/25497

http://secunia.com/advisories/26083

http://secunia.com/advisories/26413

http://security.gentoo.org/glsa/glsa-200703-28.xml

http://support.avaya.com/elmodocs2/security/ASA-2007-194.htm

http://www.mandriva.com/security/advisories?name=MDKSA-2007:086

http://www.novell.com/linux/security/advisories/2007_14_sr.html

http://www.novell.com/linux/security/advisories/2007_9_sr.html

http://www.redhat.com/support/errata/RHSA-2007-0123.html

http://www.securityfocus.com/archive/1/463846/100/0/threaded

http://www.securityfocus.com/bid/22948

http://www.securityfocus.com/bid/23127

http://www.securitytracker.com/id?1017750

http://www.us-cert.gov/cas/techalerts/TA07-072A.html

http://www.vupen.com/english/advisories/2007/0930

http://www.vupen.com/english/advisories/2007/0949

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=232243

https://issues.rpath.com/browse/RPL-1173

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11046

Details

Source: MITRE

Published: 2007-03-13

Updated: 2020-12-15

Risk Information

CVSS v2.0

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:cups:cups:*:*:*:*:*:*:*:*

Configuration 2

OR

cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:*

Tenable Plugins

View all (17 total)

IDNameProductFamilySeverity
79964GLSA-201412-11 : AMD64 x86 emulation base libraries: Multiple vulnerabilities (Heartbleed)NessusGentoo Local Security Checks
high
67462Oracle Linux 3 / 4 / 5 : cups (ELSA-2007-0123)NessusOracle Linux Local Security Checks
medium
29411SuSE 10 Security Update : cups (ZYPP Patch Number 3716)NessusSuSE Local Security Checks
medium
29410SuSE 10 Security Update : CUPS (ZYPP Patch Number 3137)NessusSuSE Local Security Checks
medium
28162Fedora 7 : cups-1.2.12-7.fc7 (2007-3100)NessusFedora Local Security Checks
high
27822Fedora 8 : cups-1.3.4-2.fc8 (2007-2982)NessusFedora Local Security Checks
critical
27193openSUSE 10 Security Update : cups (cups-3715)NessusSuSE Local Security Checks
medium
27192openSUSE 10 Security Update : cups (cups-3136)NessusSuSE Local Security Checks
medium
25512FreeBSD : cups -- Incomplete SSL Negotiation Denial of Service (39988ee8-1918-11dc-b6bd-0016179b2dd5)NessusFreeBSD Local Security Checks
medium
25065RHEL 3 / 4 / 5 : cups (RHSA-2007:0123)NessusRed Hat Local Security Checks
medium
25064Mandrake Linux Security Advisory : cups (MDKSA-2007:086)NessusMandriva Local Security Checks
medium
25041CentOS 3 / 4 / 5 : cups (CESA-2007:0123)NessusCentOS Local Security Checks
medium
24933GLSA-200703-28 : CUPS: Denial of ServiceNessusGentoo Local Security Checks
medium
24901CUPS Incomplete SSL Negotiation Remote DoSNessusMisc.
medium
24820Fedora Core 5 : cups-1.2.8-1.fc5 (2007-1219)NessusFedora Local Security Checks
medium
3947Mac OS X < 10.4.9 Multiple Vulnerabilities (Security Update 2007-003)Nessus Network MonitorWeb Clients
high
24811Mac OS X < 10.4.9 Multiple Vulnerabilities (Security Update 2007-003)NessusMacOS X Local Security Checks
critical