CVE-2006-6106

HIGH

Description

Multiple buffer overflows in the cmtp_recv_interopmsg function in the Bluetooth driver (net/bluetooth/cmtp/capi.c) in the Linux kernel 2.4.22 up to 2.4.33.4 and 2.6.2 before 2.6.18.6, and 2.6.19.x, allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via CAPI messages with a large value for the length of the (1) manu (manufacturer) or (2) serial (serial number) field.

References

http://kernel.org/pub/linux/kernel/v2.4/ChangeLog-2.4.33.5

http://marc.info/?l=linux-kernel&m=116614741607528&w=2

http://marc.info/?l=linux-kernel&m=116648929829440&w=2

http://rhn.redhat.com/errata/RHSA-2007-0014.html

http://secunia.com/advisories/23408

http://secunia.com/advisories/23427

http://secunia.com/advisories/23593

http://secunia.com/advisories/23609

http://secunia.com/advisories/23752

http://secunia.com/advisories/23997

http://secunia.com/advisories/24098

http://secunia.com/advisories/24105

http://secunia.com/advisories/24206

http://secunia.com/advisories/24547

http://secunia.com/advisories/25226

http://secunia.com/advisories/25683

http://secunia.com/advisories/25691

http://secunia.com/advisories/25714

http://secunia.com/advisories/27227

http://secunia.com/advisories/29058

http://support.avaya.com/elmodocs2/security/ASA-2007-063.htm

http://www.debian.org/security/2007/dsa-1304

http://www.debian.org/security/2008/dsa-1503

http://www.mandriva.com/security/advisories?name=MDKSA-2007:002

http://www.mandriva.com/security/advisories?name=MDKSA-2007:012

http://www.mandriva.com/security/advisories?name=MDKSA-2007:025

http://www.novell.com/linux/security/advisories/2007_18_kernel.html

http://www.novell.com/linux/security/advisories/2007_21_kernel.html

http://www.novell.com/linux/security/advisories/2007_30_kernel.html

http://www.novell.com/linux/security/advisories/2007_35_kernel.html

http://www.novell.com/linux/security/advisories/2007_53_kernel.html

http://www.securityfocus.com/archive/1/459615/100/0/threaded

http://www.securityfocus.com/archive/1/471457

http://www.securityfocus.com/bid/21604

http://www.trustix.org/errata/2007/0002/

http://www.ubuntu.com/usn/usn-416-1

http://www.vupen.com/english/advisories/2006/5037

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=218602

https://exchange.xforce.ibmcloud.com/vulnerabilities/30912

https://issues.rpath.com/browse/RPL-848

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10891

Details

Source: MITRE

Published: 2006-12-19

Updated: 2018-10-17

Type: CWE-119

Risk Information

CVSS v2.0

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH