CVE-2006-3469

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Format string vulnerability in time.cc in MySQL Server 4.1 before 4.1.21 and 5.0 before 1 April 2006 allows remote authenticated users to cause a denial of service (crash) via a format string instead of a date as the first parameter to the date_format function, which is later used in a formatted print call to display the error message.

References

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=375694

http://bugs.mysql.com/bug.php?id=20729

http://dev.mysql.com/doc/refman/4.1/en/news-4-1-21.html

http://docs.info.apple.com/article.html?artnum=305214

http://lists.apple.com/archives/security-announce/2007/Mar/msg00002.html

http://secunia.com/advisories/21147

http://secunia.com/advisories/21366

http://secunia.com/advisories/24479

http://secunia.com/advisories/31226

http://security.gentoo.org/glsa/glsa-200608-09.xml

http://www.debian.org/security/2006/dsa-1112

http://www.redhat.com/support/errata/RHSA-2008-0768.html

http://www.securityfocus.com/bid/19032

http://www.ubuntu.com/usn/usn-321-1

http://www.us-cert.gov/cas/techalerts/TA07-072A.html

http://www.vupen.com/english/advisories/2007/0930

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A9827

Details

Source: MITRE

Published: 2006-07-21

Updated: 2019-12-17

Type: CWE-134

Risk Information

CVSS v2

Base Score: 4

Vector: AV:N/AC:L/Au:S/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8

Severity: MEDIUM

Tenable Plugins

View all (12 total)

IDNameProductFamilySeverity
60451Scientific Linux Security Update : mysql on SL4.x i386/x86_64NessusScientific Linux Local Security Checks
medium
17800MySQL < 4.1.21 / 5.0 Denial of ServiceNessusDatabases
medium
33585RHEL 4 : mysql (RHSA-2008:0768)NessusRed Hat Local Security Checks
medium
27899Ubuntu 5.10 : mysql-dfsg-4.1 vulnerability (USN-321-1)NessusUbuntu Local Security Checks
medium
3947Mac OS X < 10.4.9 Multiple Vulnerabilities (Security Update 2007-003)Nessus Network MonitorWeb Clients
high
24811Mac OS X < 10.4.9 Multiple Vulnerabilities (Security Update 2007-003)NessusMacOS X Local Security Checks
critical
24656Slackware 10.2 : mysql (SSA:2006-211-01)NessusSlackware Local Security Checks
medium
22654Debian DSA-1112-1 : mysql-dfsg-4.1 - several vulnerabilitiesNessusDebian Local Security Checks
medium
22213FreeBSD : mysql -- format string vulnerability (fcb90eb0-2ace-11db-a6e2-000e0c2e438a)NessusFreeBSD Local Security Checks
medium
22167GLSA-200608-09 : MySQL: Denial of ServiceNessusGentoo Local Security Checks
medium
3527Oracle MySQL Remote Overflow and Information Disclosure VulnerabilitiesNessus Network MonitorDatabase
medium
801163MySQL Remote Overflow and Information Disclosure VulnerabilitiesLog Correlation EngineDatabase
medium