CVE-2006-1442

HIGH

Description

The bundle API in CoreFoundation in Apple Mac OS X 10.3.9 and 10.4.6 loads dynamic libraries even if the client application has not directly requested it, which allows attackers to execute arbitrary code from an untrusted bundle.

References

http://lists.apple.com/archives/security-announce/2006/May/msg00003.html

http://secunia.com/advisories/20077

http://securitytracker.com/id?1016080

http://www.osvdb.org/25586

http://www.securityfocus.com/bid/17951

http://www.us-cert.gov/cas/techalerts/TA06-132A.html

http://www.vupen.com/english/advisories/2006/1779

https://exchange.xforce.ibmcloud.com/vulnerabilities/26407

Details

Source: MITRE

Published: 2006-05-12

Updated: 2017-07-20

Risk Information

CVSS v2.0

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH