CVE-2005-4837

high

Description

snmp_api.c in snmpd in Net-SNMP 5.2.x before 5.2.2, 5.1.x before 5.1.3, and 5.0.x before 5.0.10.2, when running in master agentx mode, allows remote attackers to cause a denial of service (crash) by causing a particular TCP disconnect, which triggers a free of an incorrect variable, a different vulnerability than CVE-2005-2177.

References

http://secunia.com/advisories/25114

http://secunia.com/advisories/25115

http://secunia.com/advisories/25411

http://sourceforge.net/tracker/index.php?func=detail&aid=1207023&group_id=12694&atid=112694

http://sunsolve.sun.com/search/document.do?assetkey=1-26-102929-1

http://www.securityfocus.com/bid/23762

http://www.ubuntu.com/usn/USN-456-1

http://www.vupen.com/english/advisories/2007/1944

https://issues.rpath.com/browse/RPL-1334

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A9442

Details

Source: MITRE

Published: 2005-12-31

Updated: 2017-10-11

Type: CWE-16

Risk Information

CVSS v2

Base Score: 10

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 10

Severity: HIGH