CVE-2005-3352

MEDIUM

Description

Cross-site scripting (XSS) vulnerability in the mod_imap module of Apache httpd before 1.3.35-dev and Apache httpd 2.0.x before 2.0.56-dev allows remote attackers to inject arbitrary web script or HTML via the Referer when using image maps.

References

ftp://patches.sgi.com/support/free/security/advisories/20060101-01-U

http://docs.info.apple.com/article.html?artnum=307562

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01428449

http://issues.apache.org/bugzilla/show_bug.cgi?id=37874

http://lists.apple.com/archives/security-announce/2008//May/msg00001.html

http://lists.apple.com/archives/security-announce/2008/Mar/msg00001.html

http://lists.suse.com/archive/suse-security-announce/2007-May/0005.html

http://lists.suse.de/archive/suse-security-announce/2006-Feb/0008.html

http://marc.info/?l=bugtraq&m=130497311408250&w=2

http://rhn.redhat.com/errata/RHSA-2006-0159.html

http://rhn.redhat.com/errata/RHSA-2006-0692.html

http://secunia.com/advisories/17319

http://secunia.com/advisories/18008

http://secunia.com/advisories/18333

http://secunia.com/advisories/18339

http://secunia.com/advisories/18340

http://secunia.com/advisories/18429

http://secunia.com/advisories/18517

http://secunia.com/advisories/18526

http://secunia.com/advisories/18585

http://secunia.com/advisories/18743

http://secunia.com/advisories/19012

http://secunia.com/advisories/20046

http://secunia.com/advisories/20670

http://secunia.com/advisories/21744

http://secunia.com/advisories/22140

http://secunia.com/advisories/22368

http://secunia.com/advisories/22388

http://secunia.com/advisories/22669

http://secunia.com/advisories/23260

http://secunia.com/advisories/25239

http://secunia.com/advisories/29420

http://secunia.com/advisories/29849

http://secunia.com/advisories/30430

http://securitytracker.com/id?1015344

http://slackware.com/security/viewer.php?l=slackware-security&y=2006&m=slackware-security.470158

http://slackware.com/security/viewer.php?l=slackware-security&y=2006&m=slackware-security.685483

http://sunsolve.sun.com/search/document.do?assetkey=1-26-102662-1

http://sunsolve.sun.com/search/document.do?assetkey=1-26-102663-1

http://www.debian.org/security/2006/dsa-1167

http://www.gentoo.org/security/en/glsa/glsa-200602-03.xml

http://www.novell.com/linux/security/advisories/2006_43_apache.html

http://www.openpkg.org/security/OpenPKG-SA-2005.029-apache.txt

http://www.oracle.com/technetwork/topics/security/cpujuly2013-1899826.html

http://www.redhat.com/archives/fedora-announce-list/2006-January/msg00060.html

http://www.redhat.com/support/errata/RHSA-2006-0158.html

http://www.securityfocus.com/archive/1/425399/100/0/threaded

http://www.securityfocus.com/archive/1/445206/100/0/threaded

http://www.securityfocus.com/archive/1/450315/100/0/threaded

http://www.securityfocus.com/archive/1/450321/100/0/threaded

http://www.securityfocus.com/bid/15834

http://www.trustix.org/errata/2005/0074/

http://www.ubuntulinux.org/usn/usn-241-1

http://www.us-cert.gov/cas/techalerts/TA08-150A.html

http://www.vupen.com/english/advisories/2005/2870

http://www.vupen.com/english/advisories/2006/2423

http://www.vupen.com/english/advisories/2006/3995

http://www.vupen.com/english/advisories/2006/4015

http://www.vupen.com/english/advisories/2006/4300

http://www.vupen.com/english/advisories/2006/4868

http://www.vupen.com/english/advisories/2008/0924/references

http://www.vupen.com/english/advisories/2008/1246/references

http://www.vupen.com/english/advisories/2008/1697

http://www-1.ibm.com/support/search.wss?rs=0&q=PK16139&apar=only

http://www-1.ibm.com/support/search.wss?rs=0&q=PK25355&apar=only

http://wwwnew.mandriva.com/security/advisories?name=MDKSA-2006:007

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10480

Details

Source: MITRE

Published: 2005-12-13

Updated: 2021-03-30

Risk Information

CVSS v2.0

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:apache:http_server:1.3:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.0:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.1:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.2:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.3:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.4:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.5:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.6:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.7:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.7:*:dev:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.8:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.9:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.10:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.11:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.11:*:win32:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.12:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.12:*:win32:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.13:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.13:*:win32:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.14:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.14:*:mac_os:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.14:*:win32:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.15:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.15:*:win32:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.16:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.16:*:win32:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.17:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.17:*:win32:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.18:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.18:*:win32:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.19:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.19:*:win32:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.20:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.20:*:win32:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.22:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.22:*:win32:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.23:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.23:*:win32:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.24:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.24:*:win32:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.25:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.25:*:win32:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.26:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.26:*:win32:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.27:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.28:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.29:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.30:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.31:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:1.3.32:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0.9:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0.28:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0.28:beta:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0.28:beta:win32:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0.32:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0.32:beta:win32:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0.34:beta:win32:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0.35:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0.36:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0.37:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0.38:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0.39:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0.40:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0.41:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0.42:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0.43:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0.44:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0.45:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0.46:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0.47:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0.48:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0.49:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0.50:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0.51:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0.52:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0.53:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0.54:*:*:*:*:*:*:*

cpe:2.3:a:apache:http_server:2.0.55:*:*:*:*:*:*:*

cpe:2.3:a:apache:mod_imap:*:*:*:*:*:*:*:*

Tenable Plugins

View all (35 total)

IDNameProductFamilySeverity
127360NewStart CGSL MAIN 4.05 : httpd Multiple Vulnerabilities (NS-SA-2019-0118)NessusNewStart CGSL Local Security Checks
critical
69301Oracle Fusion Middleware Oracle HTTP Server Multiple VulnerabilitiesNessusWeb Servers
critical
63857RHEL 3 / 4 : Proxy Server (RHSA-2008:0523)NessusRed Hat Local Security Checks
high
41124SuSE9 Security Update : Apache (YOU Patch Number 11489)NessusSuSE Local Security Checks
medium
32478Mac OS X Multiple Vulnerabilities (Security Update 2008-003)NessusMacOS X Local Security Checks
critical
32477Mac OS X 10.5.x < 10.5.3 Multiple VulnerabilitiesNessusMacOS X Local Security Checks
critical
31647Apache mod_imap Image Map Referer XSSNessusWeb Servers
medium
31605Mac OS X Multiple Vulnerabilities (Security Update 2008-002)NessusMacOS X Local Security Checks
critical
29372SuSE 10 Security Update : Apache2 (ZYPP Patch Number 1906)NessusSuSE Local Security Checks
high
29200HP-UX PHSS_37141 : s700_800 11.X OV NNM6.4x/ET2.0x Intermediate Patch 17NessusHP-UX Local Security Checks
critical
26896HP-UX PHSS_36773 : s700_800 11.X OV NNM7.01 Intermediate Patch 11NessusHP-UX Local Security Checks
critical
26155HP-UX PHSS_36386 : HP OpenView Network Node Manager (OV NNM) Running Apache, Remote Cross Site Scripting (XSS), Denial of Service (DoS), Execute Arbitrary Code (HPSBMA02328 SSRT071293 rev.2)NessusHP-UX Local Security Checks
high
26154HP-UX PHSS_36385 : HP OpenView Network Node Manager (OV NNM) Running Apache, Remote Cross Site Scripting (XSS), Denial of Service (DoS), Execute Arbitrary Code (HPSBMA02328 SSRT071293 rev.2)NessusHP-UX Local Security Checks
high
23721HP-UX PHSS_35463 : s700_800 11.04 Virtualvault 4.7 (Apache 1.x) OWS updateNessusHP-UX Local Security Checks
high
23720HP-UX PHSS_35462 : s700_800 11.04 Virtualvault 4.6 OWS updateNessusHP-UX Local Security Checks
high
23719HP-UX PHSS_35461 : s700_800 11.04 Virtualvault 4.5 OWS updateNessusHP-UX Local Security Checks
high
23718HP-UX PHSS_35460 : s700_800 11.04 Virtualvault 4.7 IWS updateNessusHP-UX Local Security Checks
high
23717HP-UX PHSS_35459 : s700_800 11.04 Virtualvault 4.6 IWS updateNessusHP-UX Local Security Checks
high
23716HP-UX PHSS_35458 : s700_800 11.04 Virtualvault 4.5 IWS UpdateNessusHP-UX Local Security Checks
high
23715HP-UX PHSS_35437 : s700_800 11.04 Webproxy server 2.1 (Apache 2.x) updateNessusHP-UX Local Security Checks
high
23714HP-UX PHSS_35436 : s700_800 11.04 Virtualvault 4.7 OWS (Apache 2.x) updateNessusHP-UX Local Security Checks
high
23713HP-UX PHSS_35111 : s700_800 11.04 Webproxy 2.1 (Apache 1.x) updateNessusHP-UX Local Security Checks
high
23712HP-UX PHSS_35110 : s700_800 11.04 Webproxy server 2.0 updateNessusHP-UX Local Security Checks
high
22709Debian DSA-1167-1 : apache - missing input sanitising NessusDebian Local Security Checks
medium
21884CentOS 3 / 4 : httpd (CESA-2006:0159)NessusCentOS Local Security Checks
medium
21487FreeBSD : apache -- mod_imap XSS flaw (9fff8dc8-7aa7-11da-bf72-00123f589060)NessusFreeBSD Local Security Checks
medium
21346Slackware 10.0 / 10.1 / 10.2 / 8.1 / 9.0 / 9.1 / current : Apache httpd redux (SSA:2006-130-01)NessusSlackware Local Security Checks
medium
21344Slackware 10.0 / 10.1 / 10.2 / 8.1 / 9.0 / 9.1 / current : Apache httpd (SSA:2006-129-01)NessusSlackware Local Security Checks
medium
20874GLSA-200602-03 : Apache: Multiple vulnerabilitiesNessusGentoo Local Security Checks
medium
20788Ubuntu 4.10 / 5.04 / 5.10 : apache2, apache vulnerabilities (USN-241-1)NessusUbuntu Local Security Checks
medium
20757Fedora Core 4 : httpd-2.0.54-10.3 (2006-052)NessusFedora Local Security Checks
medium
20733RHEL 2.1 : apache (RHSA-2006:0158)NessusRed Hat Local Security Checks
medium
20473Mandrake Linux Security Advisory : apache2 (MDKSA-2006:007)NessusMandriva Local Security Checks
medium
20398RHEL 3 / 4 : httpd (RHSA-2006:0159)NessusRed Hat Local Security Checks
medium
4523Mac OS X < 10.5.3Nessus Network MonitorGeneric
critical