CVE-2005-3180

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The Orinoco driver (orinoco.c) in Linux kernel 2.6.13 and earlier does not properly clear memory from a previously used packet whose length is increased, which allows remote attackers to obtain sensitive information.

References

http://marc.info/?l=bugtraq&m=112914754708402&w=2

http://secunia.com/advisories/17114

http://secunia.com/advisories/17280

http://secunia.com/advisories/17364

http://secunia.com/advisories/17826

http://secunia.com/advisories/17917

http://secunia.com/advisories/17918

http://secunia.com/advisories/18562

http://secunia.com/advisories/18684

http://secunia.com/advisories/19374

http://securityreason.com/securityalert/75

http://www.debian.org/security/2006/dsa-1017

http://www.kernel.org/hg/linux-2.6/?cmd=changeset;node=feecb2ffde28639e60ede769c6f817dc536c677b

http://www.mandriva.com/security/advisories?name=MDKSA-2005:218

http://www.mandriva.com/security/advisories?name=MDKSA-2005:219

http://www.mandriva.com/security/advisories?name=MDKSA-2005:220

http://www.mandriva.com/security/advisories?name=MDKSA-2005:235

http://www.redhat.com/support/errata/RHSA-2005-808.html

http://www.redhat.com/support/errata/RHSA-2006-0140.html

http://www.redhat.com/support/errata/RHSA-2006-0190.html

http://www.redhat.com/support/errata/RHSA-2006-0191.html

http://www.securityfocus.com/advisories/9549

http://www.securityfocus.com/advisories/9806

http://www.securityfocus.com/archive/1/419522/100/0/threaded

http://www.securityfocus.com/archive/1/427980/100/0/threaded

http://www.securityfocus.com/archive/1/428028/100/0/threaded

http://www.securityfocus.com/archive/1/428058/100/0/threaded

http://www.securityfocus.com/bid/15085

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11332

https://usn.ubuntu.com/219-1/

Details

Source: MITRE

Published: 2005-10-12

Updated: 2018-10-19

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* versions up to 2.6.13 (inclusive)

Tenable Plugins

View all (13 total)

IDNameProductFamilySeverity
65105Ubuntu 4.10 / 5.10 : linux-source-2.6.8.1/-2.6.10/-2.6.12 vulnerabilities (USN-219-1)NessusUbuntu Local Security Checks
medium
22559Debian DSA-1017-1 : kernel-source-2.6.8 - several vulnerabilitiesNessusDebian Local Security Checks
critical
21967CentOS 4 : kernel (CESA-2005:808)NessusCentOS Local Security Checks
medium
21881CentOS 3 : kernel (CESA-2006:0140)NessusCentOS Local Security Checks
high
20855RHEL 2.1 : kernel (RHSA-2006:0191)NessusRed Hat Local Security Checks
medium
20751RHEL 3 : kernel (RHSA-2006:0140)NessusRed Hat Local Security Checks
high
20466Mandrake Linux Security Advisory : kernel (MDKSA-2005:235)NessusMandriva Local Security Checks
medium
20451MDKSA-2005:220 : kernelNessusMandriva Local Security Checks
medium
20450Mandrake Linux Security Advisory : kernel (MDKSA-2005:219)NessusMandriva Local Security Checks
high
20104RHEL 4 : kernel (RHSA-2005:808)NessusRed Hat Local Security Checks
medium
20073Fedora Core 3 : kernel-2.6.12-1.1380_FC3 (2005-1007)NessusFedora Local Security Checks
medium
801415CentOS RHSA-2006-0140 Security CheckLog Correlation EngineGeneric
high
801412CentOS RHSA-2005-808 Security CheckLog Correlation EngineGeneric
high