Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Apache Subversion 1.8.x < 1.8.17 / 1.9.x < 1.9.5 DoS

Medium

Synopsis

The remote host is running a version of Apache Subversion (SVN) that is affected by a Denial of Service (DoS) attack vector.

Description

The version of Apache Subversion installed on the remote host is version 1.8.x prior to 1.8.17 or 1.9.x prior to 1.9.5. It is, therefore, affected by an XXE (Xml eXternal Entity) injection flaw in the 'mod_dontdothat' module in 'libsvn_ra_serf/xml.c' that is triggered during the parsing of XML data. The issue is due to an incorrectly configured XML parser accepting XML external entities from an untrusted source. By sending specially crafted XML data, a remote attacker can exhaust available resources.

Solution

Upgrade to Apache Subversion 1.9.5 or later. If 1.9.5 cannot be obtained, 1.8.17 is also patched for these vulnerabilities.