Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Apache Tomcat 7.0.x < 7.0.73 / 8.0.x < 8.0.39 / 8.5.x < 8.5.8 / 9.x < 9.0.0.M13 DoS

Medium

Synopsis

The remote web server is missing an Apache Tomcat patch update.

Description

The version of Apache Tomcat installed on the remote host is version 7.0.x prior to 7.0.73, 8.0.x prior to 8.0.39, 8.5.x prior to 8.5.8, or 9.x prior to 9.0.0.M13, and is affected by multiple vulnerabilities :

- A flaw exists that is triggered when handling request lines containing certain invalid characters. This allows a remote attacker to inject additional headers into responses to conduct HTTP response splitting attacks. (CVE-2016-6816) - An infinite loop condition exists in the HTTP/2 parser that is triggered when handling overly large headers. With a specially crafted request, a remote attacker can cause a denial of service. (CVE-2016-6817) - A flaw exists in 'catalina/mbeans/JmxRemoteLifecycleListener.java' that is triggered during the deserialization of Java objects. This may allow a remote attacker to potentially execute arbitrary code. (CVE-2016-8735)

Solution

Update to Apache Tomcat version 9.0.0.M13 or later. If version 9.x cannot be obtained, versions 8.5.8, 8.0.39, and 7.0.73 have also been patched for these vulnerabilities.