Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Oracle MySQL 5.6.x < 5.6.34 Multiple Vulnerabilities

Critical

Synopsis

The remote database server is vulnerable to multiple attack vectors.

Description

The version of MySQL installed on the remote host is version 5.6.x prior to 5.6.34 and is affected by multiple issues :

- An unspecified flaw exists related to the Security: Encryption subcomponent. This may allow an authenticated remote attacker to disclose potentially sensitive information. No further details have been provided by the vendor. (CVE-2016-5584) - A flaw exists that may allow a local attacker with DBA permissions to gain elevated privileges. The issue is due to the program not properly restricting the ability to write to configuration files (e.g. my.cnf), combined with it loading a configuration file from specific locations that current versions do not use (e.g. /var/lib/mysql/my.cnf). This may allow an attacker to leverage specially crafted queries to use logging functionality to create new files or append custom content to existing files. By placing a custom .cnf file that MySQL will load, with a 'malloc_lib=' directive pointing to an attacker controlled 'mysql_hookandroot_lib.so' file, the attacker can cause MySQL to read the configuration file and load the malicious library the next time it starts. This can allow the attacker to gain root privileges. (CVE-2016-6662)

Solution

Upgrade to MySQL 5.6.34 or later.