icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Oracle MySQL 5.7.x < 5.7.13 Multiple Vulnerabilities

High

Synopsis

The remote database server is vulnerable to multiple attack vectors.

Description

The version of MySQL installed on the remote host is version 5.7.x prior to 5.7.13 and is affected by multiple issues :

- Multiple flaws exist in InnoDB that are triggered when handling specially crafted 'ALTER TABLE' operations. This may allow an authenticated attacker to potentially crash the database. (OSVDB 139551) - Multiple unspecified overflow conditions exist that are triggered as user-supplied input is not properly validated. This may allow an authenticated attacker to cause a buffer overflow, resulting in a denial of service or potentially allowing the execution of arbitrary code. (OSVDB 139552) - A NULL pointer dereference flaw exists in a parser structure that is triggered during the validation of stored procedure names. This may allow an authenticated attacker to potentially cause the database to crash. (OSVDB 139553) - Multiple unspecified overflow conditions exist in the InnoDB memcached plugin that are triggered as user-supplied input is not properly validated. This may allow an authenticated attacker to cause a buffer overflow, resulting in a denial of service or potentially allowing the execution of arbitrary code. (OSVDB 139554) - A flaw exists that is triggered when invoking Enterprise Encryption functions in multiple threads simultaneously or after creating and dropping them. This may allow an authenticated attacker to potentially crash the database. (OSVDB 139555) - A flaw exists that is triggered when handling a 'SELECT ... GROUP BY ... FOR UPDATE' query executed with a Loose Index Scan. This may allow an authenticated attacker to potentially crash the database. (OSVDB 139556) - A flaw exists that is triggered when performing a 'FLUSH TABLES' operation on a table with a discarded tablespace. This may potentially allow an authenticated attacker to cause the database to crash. (OSVDB 139558) - A flaw exists in InnoDB that is triggered when performing an 'OPTIMIZE TABLE' operation on a table with a full-text index. This may allow an authenticated attacker to crash the database. (OSVDB 139559) - A flaw exists that is triggered when performing an 'UPDATE' operation on a generated virtual BLOB column. This may potentially allow an authenticated attacker to cause the database to crash. (OSVDB 139560) - A flaw exists that is triggered when performing a 'SHOW CREATE TABLE' operation on a table with a generated column. This may potentially allow an authenticated attacker to cause the database to crash. (OSVDB 139561) - An unspecified flaw exists related to the InnoDB Plugin subcomponent. This may allow an authenticated remote attacker to have an impact on integrity. No further details have been provided by the vendor. (OSVDB 146000)

Solution

Upgrade to MySQL 5.7.13 or later.