Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

MariaDB Server 5.5.x < 5.5.50 DoS

Medium

Synopsis

The remote database server is affected by a Denial of Service (DoS) attack vector.

Description

MariaDB is a community-developed fork of the MySQL relational database. The version of MariaDB installed on the remote host is 5.5.x earlier than 5.5.50, and is therefore affected by a flaw in the 'Item_func_match::fix_index()' function in 'sql/item_func.cc' that is triggered during the handling of a full-text search of the 'utf8mb4' column. This may allow an authenticated attacker to crash the database. (OSVDB 140239)

Solution

Upgrade to version 5.5.50 or later.