CUPS < 1.7.1 Local Privilege Escalation Vulnerability

Low

Synopsis

The remote host is running a program that is vulnerable to privilege escalation.

Description

CUPS is a *nix-based network printing program. Versions of CUPS earlier than 1.7.1 may contain a flaw in the lppasswd program due to incorrect use of settings from the '~/.cups/client.conf' file.

Solution

Upgrade to CUPS 1.7.1 or later.