icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

VLC Media Player < 1.1.8 Multiple Buffer Overflows

High

Synopsis

The remote host contains an application that allows arbitrary code execution.

Description

The remote host contains VLC player, a multi-media application.

Versions of VLC media player earlier than 1.1.8 are potentially affected by buffer overflow vulnerabilities when handling specially crafted AMV and NSV files, which could result in arbitrary code execution.

Solution

Upgrade to VLC Media Player version 1.1.8 or later.