icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Asterisk main/udptl.c Buffer Overflows (AST-2011-002)

High

Synopsis

The remote VoIP server is affected by multiple buffer overflow vulnerabilities.

Description

The version of Asterisk running on the remote host may be vulnerable to heap- and stack-buffer overflow attacks with specially crafted UDPTL packets.

Successful exploitation requires T.38 support to be enabled on the target, which is not the default, and can allow execution of arbitrary code in the context of the Asterisk server or an application crash.

Solution

Upgrade to Asterisk 1.4.39.2, 1.6.1.22, 1.6.2.16.2, 1.8.2.4, or later or Asterisk Business Edition C.3.6.3 or later.\nAlternatively, disable T.38 support by setting 't38pt_udptl' to 'no' in sip.conf and ensuring that the chan_ooh323 module is not loaded.