icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

EvoCam < 3.6.8 GET Request Buffer Overflow

High

Synopsis

The remote host contains an application that is affected by a buffer overflow vulnerability.

Description

The remote host is running EvoCam, a webcam application for Mac OS X.

Versions of EvoCam earlier than 3.6.8 are potentially affected by a buffer overflow vulnerability in the web server when handling specially crafted GET requests. An attacker, exploiting this flaw, could execute arbitrary code on the remote host subject to the privileges of the user running the affected software.

Solution

Upgrade to EvoCam 3.6.8 or later.