icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Adobe Flash Media Server < 3.0.5 / 3.5.3 Multiple Vulnerabilities (APSB09-018) (RTMP over HTTP)

High

Synopsis

The remote host is vulnerable to multiple attack vectors

Description

The remote host is running Adobe Flash Media server. The installed version of Adobe Flash Media server appears to be earlier than 3.0.5 or 3.5.3. Such versions are potentially affected by multiple vulnerabilities :

- A resource exhaustion vulnerability that could lead to a denial of service. (CVE-2009-3791)

- A directory traversal vulnerability that could lead to FMS loading arbitrary DLLs present on the server. (CVE-2009-3792)

Solution

Upgrade to Adobe Flash Media Server 3.0.5, 3.5.3 or later.