icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Mac OS X Safari < 3.1 Multiple Vulnerabilities

High

Synopsis

The remote host web browser is affected by multiple vulnerabilities.

Description

The remote Mac OS X host is running a version of Safari that is older than version 3.1. The remote version of this software contains several security vulnerabilities that may allow an attacker to execute arbitrary code or a cross-site scripting attack on the remote host. To exploit these flaws, an attacker would need to convince a victim to visit a rogue web site or open a malicious HTML file.

Solution

Upgrade to version 3.1 or higher.