icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

PostgreSQL Multiple Vulnerabilities

High

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote host is running PostgreSQL, an open source relational database. This version is vulnerable to six distinct remote flaws. The nature of three of these flaws involves privilege escalation. An attacker exploiting the 'privilege escalation' bugs would either need local access or user credentials in order to elevate their access. The other three flaws involve remote denial of service attacks. An attacker exploiting these flaws would not need any sort of credentials and would have the ability to crash the database service.

Solution

Upgrade to PostgreSQL 7.3.21, 7.4.19, 8.0.15, 8.1.11, 8.2.6 or higher.