icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Samba < 3.0.24 'nss_winbind.so.1' Multiple Function Overflow

Medium

Synopsis

The remote host is vulnerable to a buffer overflow.

Description

The remote Samba server, according to its version number, may be vulnerable to multiple remote buffer overflows. The flaw appears to be in the way that Samba handles very long responses to 'gethostbyname' and 'getipnodebyname' name resolution. An attacker exploiting this flaw would only need to be able to send a very long name to the vulnerable application. Successful exploitation would result in the attacker executing arbitrary code on the Samba server.

Solution

Upgrade to version 3.0.24 or higher.