phpMyAdmin 4.0.x < 4.0.10.2 / 4.1.x < 4.1.14.3 / 4.2.x < 4.2.7.1 Multiple XSS Vulnerabilities (PMASA-2014-8 - PMASA-2014-9)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote web server hosts a PHP application that is affected by
multiple vulnerabilities.

Description :

According to its self-reported version number, the phpMyAdmin
application hosted on the remote web server is 4.0.x prior to
4.0.10.2, 4.1.x prior to 4.1.14.3, or 4.2.x prior to 4.2.7.1. It is,
therefore, affected by the following vulnerabilities :

- Multiple cross-site scripting vulnerabilities exist in
the browser table, ENUM editor, monitor, query charts,
and table relations pages. (CVE-2014-5273)

- A flaw exists in the view operation page that allows a
cross-site scripting attack. Note that this does not
affect the 4.0.x releases. (CVE-2014-5274)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

http://www.phpmyadmin.net/home_page/security/PMASA-2014-8.php
http://www.phpmyadmin.net/home_page/security/PMASA-2014-9.php
http://www.nessus.org/u?fea869a4
http://www.nessus.org/u?1e1c0339
http://www.nessus.org/u?b49d1fce
http://www.nessus.org/u?274b0651
http://www.nessus.org/u?cec3b0ca
http://www.nessus.org/u?b6efd2e6

Solution :

Either upgrade to phpMyAdmin 4.0.10.2 / 4.1.14.3 / 4.2.7.1 or later,
or apply the patches from the referenced links.

Risk factor :

Low / CVSS Base Score : 3.5
(CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N)
CVSS Temporal Score : 3.0
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 77305 ()

Bugtraq ID: 69268
69269

CVE ID: CVE-2014-5273
CVE-2014-5274