BlackBerry < 10.2.0.1443 Multiple Vulnerabilities

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The version of BlackBerry 10 OS is affected by multiple
vulnerabilities.

Description :

The mobile device uses a version of BlackBerry 10 OS that is older
than version 10.2.0.1443. It is, therefore, affected by multiple
vulnerabilities related to Adobe Flash Player including memory
corruption vulnerabilities that could allow arbitrary, remote code
execution.

Note that this plugin has relied solely on the version of the
installed OS.

See also :

http://www.blackberry.com/btsc/KB35925

Solution :

Upgrade to BlackBerry 10.2.0.1443 or later.

Alternatively, refer to the vendor's advisory for mitigation steps
involving disabling Flash content in the browser.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false