Puppet Dashboard Multiple XSS Vulnerabilities

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

A web application on the remote host is potentially affected by
multiple cross-site scripting vulnerabilities.

Description :

According to its self-reported version number, the Puppet Dashboard
install on the remote host is later than version 1.0 but prior to
1.2.5. It is, therefore, affected by multiple cross-site scripting
vulnerabilities.

Multiple cross-site scripting flaws exist where unspecified input is
not validated before being returned to the user. This could allow a
remote attacker to execute arbitrary code within the browser and
server trust relationship.

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

http://puppetlabs.com/security/cve/cve-2012-0891

Solution :

Upgrade to Puppet Dashboard 1.2.5 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 73823 ()

Bugtraq ID: 66602

CVE ID: CVE-2012-0891