MediaWiki < 1.21.9 / 1.22.6 InfoAction.php XSS

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote web server contains an application that is affected by a
cross-site scripting vulnerability.

Description :

According to its version number, the instance of MediaWiki installed
on the remote host is affected by a cross-site scripting
vulnerability.

A flaw exists with 'sortKey' in the 'InfoAction.php' script. This
could allow a remote attacker to execute arbitrary code within the
server and browser trust relationship.

Nessus has not tested for this issue, but has instead relied on the
application's self-reported version number.

See also :

http://www.nessus.org/u?57bdc970
https://www.mediawiki.org/wiki/Release_notes/1.21
https://www.mediawiki.org/wiki/Release_notes/1.22
https://bugzilla.wikimedia.org/show_bug.cgi?id=63251

Solution :

Upgrade to MediaWiki version 1.21.9 / 1.22.6 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 73804 ()

Bugtraq ID: 67068

CVE ID: CVE-2014-2853