Flash Player for Mac <= 11.7.700.272 / 12.0.0.77 Multiple Vulnerabilities (APSB14-09) (Mac OS X)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host has a browser plugin that is affected by
multiple vulnerabilities.

Description :

According to its version, the instance of Flash Player installed on
the remote Mac OS X host is equal or prior to 11.7.700.272 / 11.8.x /
11.9.x / 12.0.0.77. It is, therefore, potentially affected by multiple
vulnerabilities :

- A use-after-free error exists that could lead to
arbitrary code execution. (CVE-2014-0506)

- A buffer overflow error exists that could lead to
arbitrary code execution. (CVE-2014-0507)

- An unspecified error exists that could allow a security
bypass leading to information disclosure.
(CVE-2014-0508)

- An unspecified error exists that could allow cross-
site scripting attacks. (CVE-2014-0509)

See also :

http://helpx.adobe.com/security/products/flash-player/apsb14-09.html

Solution :

Upgrade to Adobe Flash Player version 11.7.700.275 / 13.0.0.182 or
later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 73435 ()

Bugtraq ID: 66208
66699
66701
66703

CVE ID: CVE-2014-0506
CVE-2014-0507
CVE-2014-0508
CVE-2014-0509