Palo Alto Networks PAN-OS < 5.0.9 Multiple Vulnerabilities

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote host is affected by multiple vulnerabilities.

Description :

The remote host is running a version of Palo Alto Networks PAN-OS prior
to 5.0.9. It is, therefore, affected by multiple vulnerabilities :

- A security bypass vulnerability exists due to a failure
to properly enforce RADIUS users' permissions. An
authenticated attacker could potentially exploit this
vulnerability to modify shared objects. (Ref# 55287)

- A cross-site request forgery vulnerability exists due
to a failure to properly validate HTTP requests to
certain file upload forms, including
'import.certificate.php'.

- Multiple HTML injection vulnerabilities exist due to a
failure to sanitize user-supplied input to the 'Name',
'Subject' and 'Issuer' fields in imported certificates.
An attacker could exploit this vulnerability to inject
arbitrary HTML into the device's web interface.
(Ref# 57343)

See also :

https://live.paloaltonetworks.com/docs/DOC-6244

Solution :

Upgrade to PAN-OS version 5.0.9 or later.

Risk factor :

Medium / CVSS Base Score : 6.5
(CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P)
CVSS Temporal Score : 5.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Palo Alto Local Security Checks

Nessus Plugin ID: 72829 ()

Bugtraq ID: 63984
64602

CVE ID: