Palo Alto Networks PAN-OS < 3.1.10 / 4.x < 4.0.4 Multiple Command Injections

This script is Copyright (C) 2014-2015 Tenable Network Security, Inc.


Synopsis :

The remote host is affected by multiple command injection
vulnerabilities.

Description :

The remote host is running a version of Palo Alto Networks PAN-OS
prior to 3.1.10 / 4.0.4. It is, therefore, affected by multiple
command injection vulnerabilities :

- A vulnerability exists that allows an unauthenticated
user to inject commands as root on the device.
(CVE-2012-6593 / PAN-SA-2012-0004)

- A vulnerability exists that allows an authenticated user
to inject arbitrary shell commands via the CLI.
(CVE-2012-6602 / PAN-SA-2012-0013)

See also :

https://securityadvisories.paloaltonetworks.com/Home/Detail/4
https://securityadvisories.paloaltonetworks.com/Home/Detail/13

Solution :

Upgrade to PAN-OS version 3.1.10 / 4.0.4 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.4
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Palo Alto Local Security Checks

Nessus Plugin ID: 72819 ()

Bugtraq ID: 62124
62126

CVE ID: CVE-2012-6593
CVE-2012-6602