MariaDB 5.5 < 5.5.35 Multiple Vulnerabilities

This script is Copyright (C) 2014 Tenable Network Security, Inc.

Synopsis :

The remote database server is affected by multiple vulnerabilities.

Description :

The version of MariaDB 5.5 installed on the remote host is a version
prior to 5.5.35. It is, therefore, potentially affected by the
following vulnerabilities :

- Errors exist related to the following subcomponents :
Error Handling, FTS, GIS, InnoDB, Locking, Optimizer,
Partition, Performance Schema, Privileges, Replication,
and Thread Pooling. (CVE-2013-5860, CVE-2013-5881,
CVE-2013-5891, CVE-2013-5894, CVE-2013-5908,
CVE-2014-0386, CVE-2014-0393, CVE-2014-0401,
CVE-2014-0402, CVE-2014-0412, CVE-2014-0420,
CVE-2014-0427, CVE-2014-0430, CVE-2014-0431,
CVE-2014-0433, CVE-2014-0437)

- An unspecified error exists related to stored
procedures handling that could allow denial of service
attacks. (CVE-2013-5882)

- An error exists in the file 'client/' that
could allow a buffer overflow leading to denial of
service or possibly arbitrary code execution.

See also :

Solution :

Upgrade to MariaDB 5.5.35 or later.

Risk factor :

High / CVSS Base Score : 9.3
CVSS Temporal Score : 8.1
Public Exploit Available : false