nginx < 1.4.4 / 1.5.7 ngx_parse_http Security Bypass

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server is affected by a security bypass
vulnerability.

Description :

According to the self-reported version in the Server response header,
the installed version of nginx is greater than 0.8.41 but prior to 1.4.4
/ 1.5.7. It is, therefore, affected by a security bypass vulnerability
in 'ngx_http_parse.c' when a file with a space at the end of the URI is
requested.

See also :

http://nginx.org/en/security_advisories.html
http://mailman.nginx.org/pipermail/nginx-announce/2013/000125.html
http://nginx.org/en/CHANGES-1.4
http://nginx.org/en/CHANGES

Solution :

Either apply the patch manually or upgrade to nginx 1.4.4 / 1.5.7 or
later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.5
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 71117 ()

Bugtraq ID: 63814

CVE ID: CVE-2013-4547