Adobe AIR for Mac <= 3.7.0.2100 Multiple Vulnerabilities (APSB13-17)

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host contains a version of Adobe AIR that is
affected by multiple vulnerabilities.

Description :

According to its version, the instance of Adobe AIR on the remote Mac
OS X host is 3.7.0.2100 or earlier. It is, therefore, potentially
affected by multiple vulnerabilities :

- A heap-based buffer overflow vulnerability exists that
could lead to code execution. (CVE-2013-3344)

- A memory corruption vulnerability exists that could lead
to code execution. (CVE-2013-3345)

- An integer overflow exists when resampling a user-
supplied PCM buffer. (CVE-2013-3347)

See also :

http://www.adobe.com/support/security/bulletins/apsb13-17.html

Solution :

Upgrade to Adobe AIR 3.8.0.910 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: MacOS X Local Security Checks

Nessus Plugin ID: 70215 ()

Bugtraq ID: 61043
61045
61048

CVE ID: CVE-2013-3344
CVE-2013-3345
CVE-2013-3347