GLSA-201309-20 : Dropbear: Multiple vulnerabilities

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201309-20
(Dropbear: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in Dropbear. Please review
the CVE identifier and Gentoo bug referenced below for details.

Impact :

A remote attacker could send a specially crafted request to trigger a
use-after-free condition, possibly resulting in arbitrary code execution
or a Denial of Service condition. Additionally, the bundled version of
libtommath has an error in its prime number generation, which could
result in the generation of weak keys.

Workaround :

There is no known workaround at this time.

See also :

https://bugs.gentoo.org/show_bug.cgi?id=328383
http://www.gentoo.org/security/en/glsa/glsa-201309-20.xml

Solution :

All Dropbear users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-misc/dropbear-2012.55'

Risk factor :

High / CVSS Base Score : 7.1
(CVSS2#AV:N/AC:H/Au:S/C:C/I:C/A:C)
CVSS Temporal Score : 6.2
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Gentoo Local Security Checks

Nessus Plugin ID: 70160 ()

Bugtraq ID: 52159

CVE ID: CVE-2012-0920