Apache 2.0 < 2.0.65 Multiple Vulnerabilities

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server may be affected by several vulnerabilities.

Description :

According to its banner, the version of Apache 2.0 installed on the
remote host is older than 2.0.65. Such versions may be affected by
several vulnerabilities :

- A flaw exists in the byte-range filter, making it
vulnerable to denial of service. (CVE-2011-3192)

- A flaw exists in 'mod_proxy' where it doesn't properly
interact with 'RewriteRule' and 'ProxyPassMatch'
in reverse proxy configurations. (CVE-2011-3368)

- A privilege escalation vulnerability exists relating to
a heap-based buffer overflow in 'ap_pregsub' function in
'mod_setenvif' module via .htaccess file.
(CVE-2011-3607)

- A local security bypass vulnerability exists within
scoreboard shared memory that may allow the child
process to cause the parent process to crash.
(CVE-2012-0031)

- A flaw exists within the status 400 code when no custom
ErrorDocument is specified that could disclose
'httpOnly' cookies. (CVE-2012-0053)

- A flaw exists in the 'RewriteLog' function where it
fails to sanitize escape sequences written to log files,
which could result in arbitrary command execution.
(CVE-2013-1862)

Note that the remote web server may not actually be affected by these
vulnerabilities. Nessus did not try to determine whether the affected
modules are in use nor did it test for the issues themselves.

See also :

http://www.apache.org/dist/httpd/CHANGES_2.0.65
http://httpd.apache.org/security/vulnerabilities_20.html
http://www.nessus.org/u?c309d2dd

Solution :

Either ensure that the affected modules are not in use or upgrade to
Apache version 2.0.65 or later.

Risk factor :

High / CVSS Base Score : 7.8
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C)
CVSS Temporal Score : 6.8
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true