MongoDB < 2.4.5 / 2.5.1 Multiple Vulnerabilities

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.

Synopsis :

The remote database server is affected by multiple vulnerabilities.

Description :

The version of the remote MongoDB server is a version prior to
version 2.4.5 / 2.5.1. It is, therefore, potentially affected by the
following vulnerabilities :

- A remote attacker can gain elevated privileges when
authenticating as the internal __system user name for
arbitrary databases. (CVE-2013-4650)

- The JavaScript engine is vulnerable to a flaw that
could be triggered remotely to cause a segmentation
fault, or potentially arbitrary code execution.

See also :

Solution :

Upgrade to MongoDB 2.4.5 / 2.5.1 or later.

Risk factor :

Medium / CVSS Base Score : 6.5
CVSS Temporal Score : 5.7
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 67243 ()

Bugtraq ID: 61007

CVE ID: CVE-2013-3969