Samba 3.6.x < 3.6.6 Remote Security Bypass

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote Samba server is affected by a remote security bypass
vulnerability.

Description :

According to its banner, the version of Samba 3.6.x running on the
remote host is earlier than 3.6.6, and as such, it is potentially
affected by a remote security bypass vulnerability because it fails to
properly enforce CIFS share attributes.

This may allow a remote, authenticated attacker to write to read-only
shares, impact integrity related to oplock, locking, coherency, or
leases or leases attributes.

Note that Nessus has not actually tried to exploit this issue or
otherwise determine if the patch or workaround has been applied.

See also :

https://www.samba.org/samba/security/CVE-2013-0454
http://www.samba.org/samba/history/samba-3.6.6.html

Solution :

Either install the patch referenced in the project's advisory or
upgrade to 3.6.6 or later.

Risk factor :

Medium / CVSS Base Score : 4.0
(CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:N)
CVSS Temporal Score : 3.0
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 67118 ()

Bugtraq ID: 58655

CVE ID: CVE-2013-0454