MariaDB 5.5 < 5.5.29 Multiple Vulnerabilities

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote database server has multiple vulnerabilities.

Description :

The version of MariaDB 5.5 installed on the remote host is earlier than
5.5.29 and is, therefore, potentially affected by vulnerabilities in the
following components :

- Information Schema
- InnoDB
- MyISAM
- Server
- Server Locking
- Server Optimizer
- Server Parser
- Server Partition
- Server Privileges
- Server Replication
- Stored Procedure

See also :

https://kb.askmonty.org/en/mariadb-5529-release-notes/
http://dev.mysql.com/doc/refman/5.5/en/news-5-5-29.html

Solution :

Upgrade to MariaDB 5.5.29 or later.

Risk factor :

High / CVSS Base Score : 9.0
(CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C)
CVSS Temporal Score : 7.0
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true