Apache 2.2.x < 2.2.24 Multiple XSS Vulnerabilities

This script is Copyright (C) 2013-2015 Tenable Network Security, Inc.

Synopsis :

The remote web server is affected by multiple cross-site scripting

Description :

According to its banner, the version of Apache 2.2.x running on the
remote host is prior to 2.2.24. It is, therefore, potentially affected
by the following cross-site scripting vulnerabilities :

- Errors exist related to the modules mod_info,
mod_status, mod_imagemap, mod_ldap, and mod_proxy_ftp
and unescaped hostnames and URIs that could allow cross-
site scripting attacks. (CVE-2012-3499)

- An error exists related to the mod_proxy_balancer
module's manager interface that could allow cross-site
scripting attacks. (CVE-2012-4558)

Note that Nessus did not actually test for these issues, but instead
has relied on the version in the server's banner.

See also :


Solution :

Upgrade to Apache version 2.2.24 or later. Alternatively, ensure that
the affected modules are not in use.

Risk factor :

Medium / CVSS Base Score : 4.3
CVSS Temporal Score : 3.7
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 64912 ()

Bugtraq ID: 58165

CVE ID: CVE-2012-3499