OpenSSL 1.0.1 < 1.0.1e Information Disclosure

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote service may be affected by an information disclosure
vulnerability.

Description :

According to its banner, the remote web server is running a version of
OpenSSL 1.0.1 prior to 1.0.1e. The OpenSSL library is, therefore,
reportedly affected by an incomplete fix for CVE-2013-0169.

An error exists related to the SSL/TLS/DTLS protocols, CBC mode
encryption and response time. An attacker could obtain plaintext
contents of encrypted traffic via timing attacks.

See also :

http://www.nessus.org/u?109aacf1
http://www.nessus.org/u?726376ef
http://www.nessus.org/u?8275c125

Solution :

Upgrade to OpenSSL 1.0.1e or later.

Risk factor :

Low / CVSS Base Score : 2.6
(CVSS2#AV:N/AC:H/Au:N/C:P/I:N/A:N)
CVSS Temporal Score : 2.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 64620 ()

Bugtraq ID: 57778

CVE ID: CVE-2013-0169