Flash Player for Mac <= 10.3.183.50 / 11.5.502.146 Multiple Vulnerabilities (APSB13-04)

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host has a browser plugin that is affected by
multiple vulnerabilities.

Description :

According to its version, the instance of Flash Player installed on the
remote Mac OS X host is 11.x equal to or earlier than 11.5.502.146, or
10.x equal to or earlier than 10.3.183.50. It is, therefore,
potentially affected by the following vulnerabilities :

- An unspecified error exists that could allow a buffer
overflow leading to code execution. (CVE-2013-0633)

- An unspecified error exists that could allow memory
corruption leading to code execution. (CVE-2013-0634)

See also :

http://www.adobe.com/support/security/bulletins/apsb13-04.html

Solution :

Upgrade to Adobe Flash Player version 10.3.183.51 / 11.5.502.149 or
later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 64507 ()

Bugtraq ID: 57787
57788

CVE ID: CVE-2013-0633
CVE-2013-0634