Samba < 3.5.21 / 3.6.12 / 4.0.2 SWAT Multiple Vulnerabilities

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote Samba server is affected by multiple vulnerabilities.

Description :

According to its banner, the version of Samba running on the remote
host is 3.x earlier than 3.5.21 or 3.6.12 or is 4.x earlier than 4.0.1,
and is, therefore, potentially affected by the following
vulnerabilities :

- An error exists in the SWAT interface that could allow
'clickjacking' attacks. (CVE-2013-0213, Issue #9576)

- An error exists in the SWAT interface that could allow
cross-site request forgery (CSRF) attacks.
(CVE-2013-0214, Issue #9577)

Note that these issues are only exploitable when SWAT is enabled and it
is not enabled by default.

Also note that Nessus has relied only on the self-reported version
number and has not actually determined whether SWAT is enabled, tried to
exploit these issues, or determine if the associated patches have been
applied.

See also :

http://www.samba.org/samba/security/CVE-2013-0213
http://www.samba.org/samba/security/CVE-2013-0214
http://www.samba.org/samba/history/samba-4.0.2.html

Solution :

Either install the patch referenced in the project's advisory or
upgrade to 3.5.21 / 3.6.12 / 4.0.2 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 64459 ()

Bugtraq ID: 57631

CVE ID: CVE-2013-0213
CVE-2013-0214