Joomla! 2.5.x < 2.5.7 Multiple XSS

This script is Copyright (C) 2013-2017 Tenable Network Security, Inc.


Synopsis :

The remote web server contains a PHP application that is affected by
multiple cross-site scripting vulnerabilities.

Description :

According to its self-reported version number, the Joomla!
installation running on the remote web server is 2.5.x prior to 2.5.7.
It is, therefore, affected by multiple cross-site (XSS) scripting
vulnerabilities :

- A cross-site scripting (XSS) vulnerability exists in the
default_system.php script due to improper validation of
the User-Agent string before submitting it to the
sysinfo.php script. An unauthenticated, remote attacker
can exploit this, via a specially crafted request, to
execute arbitrary script code in a user's browser
session. (CVE-2012-4351)

- A cross-site scripting (XSS) vulnerability exists in the
Language Switcher module, specifically within file
modules/mod_languages/tmpl/default.php, due to improper
sanitization of input passed via 'PATH_INFO' to the
index.php script. An unauthenticated, remote attacker
can exploit this, via a specially crafted request, to
execute arbitrary script code in a user's browser
session. (CVE-2012-4352)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

http://www.nessus.org/u?611dbe83
http://www.nessus.org/u?14e8b065

Solution :

Upgrade to Joomla! version 2.5.7 or later. Alternatively, apply the
patch referenced in the vendor advisory.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.6
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 64438 ()

Bugtraq ID: 54259
55818

CVE ID: CVE-2012-4531
CVE-2012-4532

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now