This script is Copyright (C) 2012-2016 Tenable Network Security, Inc.
The remote database server is affected by multiple vulnerabilities.
The version of PostgreSQL installed on the remote host is 8.3.x prior
to 8.3.19, 8.4.x prior to 8.4.12, 9.0.x prior to 9.0.8, or 9.1.x prior
to 9.1.4. As such, it is potentially affected by multiple
- Passwords containing the byte 0x80 passed to the crypt()
function in pgcrypto are incorrectly truncated if DES
encryption was used. (CVE-2012-2143)
- SECURITY_DEFINER and SET attributes on procedural call
handlers are not ignored and can be used to crash the
See also :
Upgrade to PostgreSQL 8.3.19 / 8.4.12 / 9.0.8 / 9.1.4 or later.
Risk factor :
Medium / CVSS Base Score : 6.8
CVSS Temporal Score : 5.9
Public Exploit Available : true