DB2 9.5 < Fix Pack 10 Multiple Vulnerabilities

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by multiple issues.

Description :

According to its version, the installation of DB2 9.5 on the remote
host is affected by one or more of the following issues :

- An unspecified information disclosure error exists
related to the XML feature that can allow improper
access to arbitrary XML files. (#IC81461, CVE-2012-0713)

- An error exists related to the stored procedure
'SQLJ.DB2_INSTALL_JAR' that can allow 'JAR' files to be
overwritten. Note that this issue only affects Windows
hosts. (#IC84711, CVE-2012-2194)

- An error exists related to the stored procedures
'GET_WRAP_CFG_C' and 'GET_WRAP_CFG_C2' that can allow
unauthorized access to XML files. (#IC84712,
CVE-2012-2196)

- An error exists related to the Java stored procedure
infrastructure that can allow stack-based buffer
overflows. (#IC84752, CVE-2012-2197)

See also :

http://www-01.ibm.com/support/docview.wss?uid=swg24033308
http://www-01.ibm.com/support/docview.wss?uid=swg1IC81461
http://www-01.ibm.com/support/docview.wss?uid=swg1IC84711
http://www-01.ibm.com/support/docview.wss?uid=swg1IC84712
http://www-01.ibm.com/support/docview.wss?uid=swg1IC84752

Solution :

Apply DB2 Version 9.5 Fix Pack 10 or later.

Risk factor :

High / CVSS Base Score : 7.1
(CVSS2#AV:N/AC:H/Au:S/C:C/I:C/A:C)
CVSS Temporal Score : 5.9
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 62629 ()

Bugtraq ID: 53873
54487

CVE ID: CVE-2012-0713
CVE-2012-2194
CVE-2012-2196
CVE-2012-2197