Apache 2.4 < 2.4.3 Multiple Vulnerabilities

This script is Copyright (C) 2012-2013 Tenable Network Security, Inc.


Synopsis :

The remote web server may be affected by multiple vulnerabilities.

Description :

According to its banner, the version of Apache 2.4 installed on the
remote host is earlier than 2.4.3. It is, therefore, potentially
affected by the following vulnerabilities :

- An input validation error exists related to
'mod_negotiation', 'Multiviews' and untrusted uploads
that can allow cross-site scripting attacks.
(CVE-2012-2687)

- An error exists related to 'mod_proxy_ajp' and
'mod_proxy_http' that can allow connections to remain
open. This condition can allow information disclosure
when combined with specially crafted requests.
(CVE-2012-3502)

Note that Nessus did not actually test for these issues, but instead
has relied on the version in the server's banner.

See also :

http://www.apache.org/dist/httpd/CHANGES_2.4.3
http://httpd.apache.org/security/vulnerabilities_24.html
https://issues.apache.org/bugzilla/show_bug.cgi?id=53727

Solution :

Upgrade to Apache version 2.4.3 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N)
CVSS Temporal Score : 3.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 61644 ()

Bugtraq ID: 55131

CVE ID: CVE-2012-2687
CVE-2012-3502