Flash Player for Mac <= 10.3.183.22 / 11.4.402.264 Code Execution (APSB12-19)

This script is Copyright (C) 2012-2013 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host has a browser plugin that is affected by a
remote code execution vulnerability.

Description :

According to its version, the instance of Flash Player installed on the
remote Mac OS host is 11.x equal to or earlier than 11.4.402.264, or
10.x equal to or earlier than 10.3.183.22. It is, therefore,
potentially affected by multiple vulnerabilities :

- Multiple memory corruption vulnerabilities could lead to
code execution. (CVE-2012-4163, CVE-2012-4164,
CVE-2012-4165)

- An integer overflow vulnerability exists that could
lead to code execution. (CVE-2012-4167)

- A cross-domain information leak vulnerability exists.
(CVE-2012-4168)

- A crash can be caused by a logic error involving
multiple dialogs in Firefox. (CVE-2012-4171)

- A Matrix3D integer overflow vulnerability could lead
to code execution. (CVE-2012-5054)

See also :

http://www.securityfocus.com/archive/1/524143/30/0/threaded
http://www.adobe.com/support/security/bulletins/apsb12-19.html

Solution :

Upgrade to Adobe Flash Player version 10.3.183.23, 11.4.402.265 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.7
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 61623 ()

Bugtraq ID: 55365
55691

CVE ID: CVE-2012-4163
CVE-2012-4164
CVE-2012-4165
CVE-2012-4167
CVE-2012-4168
CVE-2012-4171
CVE-2012-5054