Quagga < 0.99.18 BGPD Multiple Denial of Service Vulnerabilities

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

The remote service may be affected by multiple denial of service
vulnerabilities.

Description :

According to its self-reported version number, the installation of
Quagga's BGP daemon listening on the remote host is affected by
multiple denial of service vulnerabilities :

- A denial of service vulnerability can be triggered by a
malformed AS_PATHLIMIT path attribute. (CVE-2010-1675)

- A denial of service vulnerability can be triggered by a
malformed extended communities attribute. (CVE-2010-1674)

See also :

https://bugzilla.quagga.net/show_bug.cgi?id=637
https://bugzilla.quagga.net/show_bug.cgi?id=638
http://savannah.nongnu.org/forum/forum.php?forum_id=7142
http://www.quagga.net/download/quagga-0.99.18.changelog.txt

Solution :

Upgrade to version 0.99.18 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.1
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 59789 ()

Bugtraq ID: 46942
46943

CVE ID: CVE-2010-1674
CVE-2010-1675