Quagga < 0.99.17 BGPD Multiple Vulnerabilities

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.

Synopsis :

The remote service may be affected by multiple vulnerabilities.

Description :

According to its self-reported version number, the installation of
Quagga's BGPD listening on the remote host is affected by multiple
vulnerabilities :

- A stack-based buffer overflow vulnerability can be
triggered by a specially crafted BGP ROUTE-REFRESH
message with a malformed Outbound Route Filtering record
sent by a pre-configured peer. (CVE-2010-2948)

- A denial of service vulnerability in BGPD can be
triggered by a specially crafted UPDATE message with an
unknown AS type in an AS path attribute.

See also :


Solution :

Upgrade to version 0.99.17 or later.

Risk factor :

High / CVSS Base Score : 9.0
CVSS Temporal Score : 6.7
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 59788 ()

Bugtraq ID: 42635

CVE ID: CVE-2010-2948