Adobe AIR for Mac 3.x <= 3.2.0.2070 Multiple Vulnerabilities (APSB12-14)

This script is Copyright (C) 2012-2013 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host contains a version of Adobe AIR that is
affected by multiple security vulnerabilities.

Description :

According to its version, the instance of Adobe AIR on the remote
Mac OS X host is 3.2.0.2070 or earlier and is reportedly affected by
multiple vulnerabilities :

- Multiple memory corruption vulnerabilities exist that
could lead to code execution. (CVE-2012-2034,
CVE-2012-2037)

- A stack overflow vulnerability exists that could lead to
code execution. (CVE-2012-2035)

- An integer overflow vulnerability exists that could lead
to code execution. (CVE-2012-2036)

- A security bypass vulnerability exists that could lead
to information disclosure. (CVE-2012-2038)

- A null dereference vulnerability exists that could lead
to code execution. (CVE-2012-2039)

See also :

http://www.adobe.com/support/security/bulletins/apsb12-14.html

Solution :

Upgrade to Adobe AIR 3.3 (3.3.0.3610) or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: MacOS X Local Security Checks

Nessus Plugin ID: 59427 ()

Bugtraq ID: 53887

CVE ID: CVE-2012-2034
CVE-2012-2035
CVE-2012-2036
CVE-2012-2037
CVE-2012-2038
CVE-2012-2039