Samba 3.x < 3.6.4 / 3.5.14 / 3.4.16 RPC Multiple Buffer Overflows

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.

Synopsis :

The remote Samba server is affected by multiple buffer overflow

Description :

According to its banner, the version of Samba 3.x running on the
remote host is earlier than 3.6.4 / 3.5.14 / 3.4.16. It is,
therefore, affected by multiple heap-based buffer overflow

An error in the DCE/RPC IDL (PIDL) compiler causes the RPC handling
code it generates to contain multiple heap-based buffer overflow
vulnerabilities. This generated code can allow a remote,
unauthenticated attacker to use malicious RPC calls to crash the
application and possibly execute arbitrary code as the root user.

Note that Nessus has not actually tried to exploit this issue or
otherwise determine if one of the associated patches has been

See also :

Solution :

Either install the appropriate patch referenced in the project's
advisory or upgrade to 3.6.4 / 3.5.14 / 3.4.16 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
CVSS Temporal Score : 8.3
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 58662 ()

Bugtraq ID: 52973

CVE ID: CVE-2012-1182