Samba 3.6.x < 3.6.3 Denial of Service

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote Samba server is affected by a denial of service
vulnerability.

Description :

According to its banner, the version of Samba 3.6.x running on the
remote host is earlier than 3.6.3. Errors exist in the files
'source3/lib/substitute.c' and 'sources3/smbd/server.c' that leak
small amounts of memory when processing every connection attempt.

An attacker can continually make connections to the server and cause a
denial of service attack against the affected smbd service.

Note that Nessus has not actually tried to exploit this issue or
otherwise determine if the patch has been applied.

See also :

http://www.samba.org/samba/security/CVE-2012-0817
http://www.samba.org/samba/history/samba-3.6.3.html
http://www.nessus.org/u?448d861a

Solution :

Either install the patch referenced in the project's advisory or
upgrade to 3.6.3 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.7
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 57752 ()

Bugtraq ID: 51713

CVE ID: CVE-2012-0817